Переворот числа

Сформировать из введенного числа обратное по порядку входящих в него цифр и вывести на экран. Например, если введено число 3486, то надо вывести число 6843.

Если постепенно извлекать из первого числа последние цифры (и удалять их после этого из числа) и постепенно «дописывать» их в конец второго, то в итоге мы получим перевернутое первое число.

  • Для извлечения последней цифры числа надо найти остаток от деления его на 10.
  • Чтобы добавить цифру в конец числа, надо умножить число на 10 (сдвинуть разряды) и затем прибавить цифру-число (количество единиц).
Pascal
перевернуть число паскаль

var
n,m: longint;
begin
readln(n);
m := 0;
while n>0 do begin
m := m*10 + n mod 10;
n := n div 10;
end;
writeln(m);
end.



560601
106065

Язык Си

#include

main() {
unsigned int n,m;
scanf("%d",&n);
m = 0;
while (n > 0) {
m = m*10 + n%10;
n = n/10;
}
printf("%d\n",m);
}



1234566
6654321
Python
перевернуть число python (питон)

n = int(input())
m = 0
while n>0:
m = m*10 + n%10
n = n//10
print(m)



45034
43054
КуМир

алг переворот числа
нач
цел n, m
ввод n
m := 0
нц пока n>0
m := m*10 + mod(n,10)
n := div(n,10)
кц
вывод m
кон



109078
870901

Basic-256

input n
m = 0
while n>0
m = m*10 + n%10
n = n\10
endwhile
print m



450287
782054

Оцените статью
Добавить комментарий