Заполнение и вывод массивов

Заполнить один массив случайными числами, другой — введенными с клавиатуры числами, в ячейки третьего записать суммы соответствующих ячеек первых двух. Вывести содержимое массивов на экран.

Все три массива должны иметь одинаковую размерность и тип.

Заполнение массива случайными числами:
Перебирать индекс массива от начала до конца, записывать в каждую его ячейку случайно сгенерированное число.

Заполнение массива значениями с клавиатуры:
Перебирать индекс массива от начала до конца, записывать в каждую его ячейку число, введенное с клавиатуры.

Заполнение массива суммами значений из других массивов:
Перебирать индекс массива от начала до конца, записывать в каждую его ячейку сумму значений из ячеек под таким же индексом из двух первых массивов.

Вывод массива на экран:
Перебирать индекс массива от начала до конца, выводить на экран значение ячейки массива под каждым индексом.

Pascal
заполнение массива паскаль

const N = 10;
var a,b,c: array[1..N] of byte;
i: byte;
begin
randomize;
for i:=1 to N do
a[i] := random(100);

write('Введите десять чисел до 100: ');
for i:=1 to N do
read(b[i]);

for i:=1 to N do
c[i] := a[i] + b[i];

for i:=1 to N do
write(a[i]:4);
writeln;
for i:=1 to N do
write(b[i]:4);
writeln;
for i:=1 to N do
write(c[i]:4);
writeln;
end.



Введите десять чисел до 100: 34 13 9 10 78 16 51 18 90 40
25 58 91 99 65 87 20 92 49 63
34 13 9 10 78 16 51 18 90 40
59 71 100 109 143 103 71 110 139 103

Язык Си

#include
#define N 10

main () {
int a[N], b[N], c[N], i;
srand(time(NULL));
for (i=0; i< N; i++)
a[i] = rand() % 100;
printf("Введите %d чисел: ", N);
for (i=0; i< N; i++)
scanf("%d", &b[i]);
for (i=0; i< N; i++)
c[i] = a[i] + b[i];

for (i=0; i< N; i++) printf("%5d", a[i]);
printf("\n");
for (i=0; i< N; i++) printf("%5d", b[i]);
printf("\n");
for (i=0; i< N; i++) printf("%5d", c[i]);
printf("\n");
}
Python
заполнение массива Python (питон)

# 1-й вариант:

from random import random
N = 10
a = [0,0,0,0,0,0,0,0,0,0]
b = [0,0,0,0,0,0,0,0,0,0]
c = [0,0,0,0,0,0,0,0,0,0]
for i in range(N):
a[i] = int(random() * 100)

print("Введите числа")
for i in range(N):
b[i] = int(input())

for i in range(N):
c[i] = a[i] + b[i]

print(a)
print(b)
print(c)

# 2-й вариант:

from random import random
N = 10
a = []
b = []
c = []
for i in range(N):
n = int(random() * 100)
a.append(n)

print("Введите числа")
for i in range(N):
n = int(input())
b.append(n)

for i in range(N):
n = a[i] + b[i]
c.append(n)

print(a)
print(b)
print(c)
КуМир

алг заполнение массивов
нач
цел таб a[1:10], b[1:10], c[1:10]
цел i
нц для i от 1 до 10
a[i] := int(rand(1,100))
кц
вывод "Введите числа:",нс
нц для i от 1 до 10
ввод b[i]
кц
нц для i от 1 до 10
c[i] := a[i] + b[i]
кц
нц для i от 1 до 10
вывод a[i], " "
кц
вывод нс
нц для i от 1 до 10
вывод b[i], " "
кц
вывод нс
нц для i от 1 до 10
вывод c[i], " "
кц
кон
Basic-256

N = 10
dim a(N)
dim b(N)
dim c(N)
for i=0 to N-1
a[i] = int(rand()*100)
next i
print "Введите числа"
for i=0 to N-1
input b[i]
next i
for i=0 to N-1
c[i] = a[i] + b[i]
next i

for i=0 to N-1
print a[i] + " ";
next i
print
for i=0 to N-1
print b[i] + " ";
next i
print
for i=0 to N-1
print c[i] + " ";
next i



Введите числа
67
89
12
30
10
50
43
32
345
70 84 95 28 46 38 10 8 43 91
67 89 12 30 10 50 43 32 0 345
137 173 107 58 56 88 53 40 43 436

Оцените статью
Добавить комментарий