Вычислить факториал числа

Вычислить факториал введенного числа.

Факториалом числа называют произведение всех натуральных чисел до этого числа включительно. Например, факториал числа 4 равен 1*2*3*4 = 24. Записывается факториал так: 4! = 24.

Поскольку факториал резко увеличивается с каждым следующим числом не следует вводить больших чисел.

  1. Присвоим переменной, накапливающей произведение натуральных чисел, начальное значение 1.
  2. Присвоим переменной-счетчику значение 2.
  3. Пока переменная счетчик не достигнет числа, введенного пользователем,
    1. умножать значение переменной, в которой накапливается произведение, на значение переменной счетчика,
    2. увеличивать счетчик на 1.
Pascal
факториал паскаль

var
n,i: byte;
f: longint;
begin
readln(n);
if n<>0 then f:=1;
for i:=2 to n do f := f*i;
writeln(f);
end.



8
40320

Язык Си

#include

main() {
unsigned short n,i;
unsigned int f;
scanf("%d",&n);
if (n != 0) f=1;
for (i=2; i<=n; i++) f*=i;
printf("%d\n",f);
}



5
120
Python
факториал python (питон)

n = int(input())
f = 0
if n > 0: f = 1
for i in range(2,n+1):
f *= i
print(f)



10
3628800
КуМир

алг факториал
нач
цел n,i,f
ввод n
f:=0
если n > 0 то f:=1 все
нц для i от 2 до n
f := f*i
кц
вывод f
кон



7
5040
Basic-256

input n
f = 0
if n>0 then f = 1
for i=2 to n
f = f * i
next i
print f



12
479001600

Оцените статью
Добавить комментарий