Количество двузначных чисел в матрице

Сформировать матрицу из чисел от 0 до 999, вывести ее на экран. Посчитать количество двузначных чисел в ней.

Следует до циклов, в которых заполняется матрица, ввести счетчик двузначных чисел. При заполнении каждой ячейки матрицы, следует проверять число. Если оно лежит в диапазоне от 10 до 99, значит оно двузначное, и следует увеличить счетчик на единицу.

Pascal

количество двузначных чисел паскаль

const
M = 7;
N = 5;
var
a: array[1..N,1..M] of integer;
i, j, count: byte;
begin
randomize;
count := 0;
for i:=1 to N do begin
for j:=1 to M do begin
a[i,j] := random(1000);
write(a[i,j]:6);
if (a[i,j] > 9) and (a[i,j] < 100) then
count := count + 1
end;
writeln;
end;
writeln('Количество двузначных чисел: ', count)
end.



Пример(ы) выполнения программы на языке Pascal:

481 356 456 213 842 82 959
59 661 52 729 932 915 663
178 224 751 362 36 121 977
473 466 470 31 288 356 147
941 138 436 971 891 616 465
Количество двузначных чисел: 5
Язык Си

сколько двузначных чисел Си

#include < stdio.h>
#define M 7
#define N 5
main() {
int a[N][M], i, j, count;
srand(time(NULL));
count = 0;
for (i=0; i< N; i++) {
for (j=0; j< M; j++) {
a[i][j] = rand() % 1000;
printf("%4d", a[i][j]);
if (a[i][j] > 9 && a[i][j] < 100)
count += 1;
}
printf("\n");
}
printf("Количество двузначных чисел: %d\n", count);
}
Python

определить двузначное число Python

from random import random
M = 7
N = 5
count = 0
a = []
for i in range(N):
b = []
for j in range(M):
n = int(random()*1000)
if 9 < n < 100:
count += 1
b.append(n)
a.append(b)

for i in a:
print(i)
print("Количество двузначных чисел: %d" % count)



[234, 646, 862, 863, 324, 718, 465]
[148, 381, 57, 577, 982, 728, 112]
[530, 878, 951, 93, 410, 252, 332]
[161, 275, 180, 235, 19, 70, 881]
[321, 226, 500, 871, 318, 685, 958]
Количество двузначных чисел: 4
КуМир

алг двузначные числа
нач
цел M = 7, N = 5
цел таб a[1:N,1:M]
цел i, j, count=0
нц для i от 1 до N
нц для j от 1 до M
a[i,j] := int(rand(0,1000))
вывод a[i,j], " "
если a[i,j] > 9 и a[i,j] < 100 то
count := count + 1
все
кц
вывод нс
кц
вывод "Количество двузначных чисел: ", count
кон
Basic-256


M = 7
N = 5
dim a(N,M)
c = 0
for i=0 to N-1
for j=0 to M-1
a[i,j] = int(rand * 1000)
print a[i,j] + " ";
if a[i,j]>9 and a[i,j]<100 then
c = c + 1
endif
next j
print
next i
print "Количество двузначных чисел: " + c



122 233 474 942 864 387 720
958 852 152 388 57 466 810
221 621 593 77 800 301 119
196 225 652 799 115 67 398
482 54 118 49 531 780 146
Количество двузначных чисел: 5

Оцените статью
Добавить комментарий